
Tungsten Automation Knowledge
When the Output Manager Console is installed without going through the normal installation procedure using the Install Assistant and Configuration Assistant (i.e., manually installed using just the .msi), Entra User logins may fail to complete or appear to hang after the user enters their credentials. This happens because a secure connection to pass the callback payload from Entra ID could not be established due to a missing system certificate. This certificate is typically created and bound to port 8069 during Configuration Assistant. When the normal installation procedure is bypassed, this certificate is not present.
To correct the issue, a self-signed certificate can be created and bound to port 8069 using the following steps:
$cert = New-SelfSignedCertificate -Subject "CN=localhost" -DnsName "localhost" -FriendlyName "localhost" -CertStoreLocation "Cert:\LocalMachine\My" -KeyExportPolicy Exportable -KeyUsage DigitalSignature,KeyEncipherment -TextExtension @("={text}..1,..2")
netsh http add sslcert ipport=:8069 certhash=$($cert.Thumbprint) appid='{1D196DD2-F1FD-4052-87EB-35F0DC7551FB}'
| Product | Version | Build | Environment | Hardware |
|---|---|---|---|---|
| ControlSuite Output Manager |
https://aio-eus-uat-cae-aif-app14-local.redglacier-35d7ee4f.eastus.azurecontainerapps.io/article/45813 | Article 000045813 | Printed Sep 30, 2026