Tungsten Automation Knowledge

Service Transformation Server (TransforamtionServerService) Could not be installed.

000031313 · Troubleshooting · Last Updated: Sep 14, 2026

Issue

The following error message is observed during the installationm of a Transformaton Server:

Service Tungsten Transformation Server (TransforamtionServerService) Could not be installed. Verify that you have sufficient privileges to install system services

Cause

The reported error refers to the missing privileges regarding the installation user. This relates to the TotalAgility Service User account specified during the installation. 

Solution

Ensure the correct user credentials is used.

For instance, the user name may need to be specific with its domain. This is in the format domain\username.

Note: This may work the other way also. Meaning, if the installation user when entered without the domain reference, then you need to only enter the username without the domain during the installaton of the transformation Server.

An "Enhancement Request 1805253:KTA 7.10 – Error messages more specific installing Transformation Server in OPMT" has been created

>>For a case, the issue was resolved for the customer after they have logged as the user, for which they have supplied the credentials for in the installer. (Upgrading from 2026.1 to 2026.2)

Level of Complexity 

Easy

Applies to  

Product Version Build Environment Hardware
TTA ALL   

References

Sections recovered from body HTML: issue, cause, solution, applies.

https://aio-eus-uat-cae-aif-app14-local.redglacier-35d7ee4f.eastus.azurecontainerapps.io/article/31313 | Article 000031313 | Printed Sep 30, 2026

Back to the article · use your browser's Print command, or save the PDF.