Get instant answers to issues or questions anytime - try our new AI Support Assistant.×

Export connectors fail to install/register when database uses Windows authentication

Home›Search›Export connectors fail to install/register when database uses Windows authentication

Export connectors fail to install/register when database uses Windows authentication

Last Updated: Sep 5, 2026|2 minute read|000043290
#TotalAgility#Knowledge#Troubleshooting

Issue

Export connectors fail to install/register when database uses Windows authentication

Cause

When installing an export connector, the installer runs RegAscSc.exe which registers the connector with the main TotalAgility database.  When the system has been configured to use Windows authentication to connect to the database, this means the specific user running the process determines whether it can connect or whether it has permissions to make updates. 

However, an additional obstacle is that RegAscSc.exe is run by the MSI and that means the Windows installer service may run it as “NT AUTHORITY\SYSTEM”, which will show in some contexts as the machine name with a dollar sign (Domain\Machine$).  The system user will not necessarily have access to the database.  If it doesn’t have access or permissions, then the installer would fail with a generic “Database error occurred” error in the UI and a more specific login or permission error in the event log.

Solution

There are a couple ways to resolve this:

Keep using Windows authentication and add permissions for machine accounts

From the SQL server, add the relevant machine name accounts (Domain\Machine$) to have permissions to connect and update the database.  The machine users for each system where export connectors need to be installed would need to be added.

Change to SQL authentication 

If wanting to change authentication for the whole system, use the Configuration Utility and change connection strings to use a SQL user instead of Windows authentication.

Or as a temporary targeted change, update MainDBConnectionString in RegAscSc.exe.config with a SQL user and password instead of using windows authentication.  This can be changed back after install if needed.  Note that providing a Windows user in the connection string will not work as that is not the same as using a SQL user.

Run from elevated command line as user with SQL access

If you can login as a Windows user who has write access to the database and Windows admin access, it may be sufficient to run the msi from an elevated command line.

Additional information

For reference, RegAscSc.exe and RegAscSc.exe.config are located in the following folder:
C:\Program Files (x86)\Tungsten\TotalAgility\ExportConnectors\bin\

Note: this applies to on-premise systems which directly connect to the database, not Integration Servers.
See: How does an Integration Server connect to a Cloud/OPMT tenant or OP system?

Why might this not be seen on a dev system?

With certain relaxed security settings, such as disabling UAC, possibly others, then, Windows installer processes may handle process elevation via the existing Windows user rather than using the system user.  That would still require that the current windows user has direct permissions to the database.  But this may explain instances where the error is not seen on a dev/all-in-one system, and is seen in other environments.


 

Applies to  

ProductVersionBuildEnvironmentHardware
 TotalAgilityAll    


 

References


 

Was this topic helpful? Like Dislike