ISSUE
Log in may be slow and CAS logs may show a delay in performing validation
Problem 1
Issue SLP Directory Agent Dynamic Discovery fails.
Event Viewer logs on Equitrac servers show Lib_SLP errors, this is a good indicator that this is the problem.
As part of the process it checks SLP for the service availability. It then waits for a response. If it doesn't get one, the connection will wait causing a delay. Debug Logs will show no service found
Example below:
The check is made here:
TRACE][2024-04-24 15:42:24.582][0x00002630][0x00000f64][EQLookupService::findServiceXML(ServiceAttribute)][0]' function enter.'
this will then respond (in this case 6 seconds later)
[TRACE][2024-04-24 15:42:30.889][0x00002630][0x00000f64][EQLookupService::findServiceXML(ServiceAttribute)][0]'No service found'
SOLUTION
To stop SLP from dynamically looking for the Directory Agent the Eqslp.conf file needs to be hardcoded on the CAS server.
There are two locations to do this.
In the top section of the file there will be an entry
;net.slp.DAAddresses = myDA1,myDA2,myDA3
Open the same file on your DRE or DCE server and you will see it populated with Values. Change the CAS value to the same
e.g. net.slp.DAAddresses = CasServer.domain.com (note there is no preceding semi colon ';')
Save this to both locations (the first is a template in case the live file is replaced, to ensure it doesn't get overwritten)
The restart CAS and SLP
This should prevent the delay.
Problem 2
Issue: SLP cannot initialize.
The SLP service typically cannot initialize due to intrusion, which may be caused by antivirus software or Crowdstrike.
SLP logs will show what happens when the SLP service initialises.
An error will be presented on initialization: "Data could not send() in SLPDOutgoingDatagramWrite"
[TRACE][2026-05-22 11:11:14.580][0x0000488c][0x00000000][slpLogDebug][25]'Query SLPKnownDA by DAAddresses equitrac.cas.domain'
[TRACE][2026-05-22 11:11:14.584][0x0000488c][0x00000000][slpLogDebug][25]'ERROR: Data could not send() in SLPDOutgoingDatagramWrite(), error code = 10049, socket 0x1cc'
[TRACE][2026-05-22 11:11:14.593][0x0000488c][0x00000000][slpLogDebug][25]'Agent Interfaces = '
[TRACE][2026-05-22 11:11:14.593][0x0000488c][0x00000000][slpLogDebug][25]'SLPD daemon scope(s): equitrac.cas.domain'
[TRACE][2026-05-22 11:11:14.593][0x0000488c][0x00000000][slpLogDebug][25]'Startup complete entering main run loop ...
'
Steps
Collect the SLP logs and SLP cache manually
logs: C:\Programdata\\ControlSuite\Logs\Equitrac\EQSlp*
Data : C:\ProgramData\Nuance\Equitrac\SLP
Send these to a Technical Support Case for review
SOLUTION
Add AV and Crowdstrike exceptions as per What are the Antivirus Exceptions required for ControlSuite?
| Product | Version | Build | Environment | Hardware |
|---|---|---|---|---|
| ControlSuite, ControlSuite Equitrac, Equitrac Office / Equitrac Express |